HowTo: VMware vSphere SDK for el Burbujea API bajo Debian instalan


Step-by-Step: Instalación de VMware vSphere el Burbujea SDK

Quién puede instalar VMware vSPhere SDK for el Burbujea para el monitoreo o los otros objetivos como Backup, etc. de modo necesitado éste muy simplemente. Dado que bajo Debian algunas vallas y dificultades hay explico muy detalladamente la instalación y llego convenientemente a los problemas.

Condiciones instalan

Dependencias siguientes son instaladas sobre el manager de paquetes
apt-get update apt-get install libssl-dev perl-doc libxml-libxml-perl libxml2-dev uuid-dev

UUID Burbujea el módulo manualmente instalan

La versión UUID que por Debian squeeze Repositories es preparada (0.02) es demasiado viejo. La solicitud mínima vsphere el Burbujea SDK está en UUID 0.03. Por eso, el módulo es cargado el UUID 0.04 (la versión más actual) manualmente y es instalado:
cd /usr/src wget http://search.cpan.org/CPAN/authors/id/J/JN/JNH/UUID-0.04.tar.gz
tar -xzvf UUID-0.04.tar.gz cd UUID-0.04 perl Makefile.PL

El manuscrito de instalación engañan

Dado que Debian no es apoyado oficialmente por VMware SDK requiere un truco pequeño instalar éste. Script busca un file/etc/*-release en el sistema operativo de modo escrito está. No somos usados faken éste simplemente como Ubuntu con eso según el estándar rpm Packages:
echo ubuntu > /etc/tmp-release
Con eso un error pequeño dónde existe todavía por VMware dos variables de alrededores prefalla. Hacemos simplemente vacío éste:
export http_proxy= export ftp_proxy=

Descarga de VMware vSphere el Burbujea SDK

VMware vSphere el Burbujea SDK no puede ser cargado por desgracia directamente en el servidor via wget allí por ello un registro y Login correspondiente en la página web VMware es necesario. La versión más actual actualmente es 5.0 y es también usada en mi instalación. SDK puede ser cargado convenientemente por 32 o 64 bites de sistemas. En mi caso uso 32 bites de sistema. Si SDK está bajado ahora esto se es quitado en el servidor a instalar bajo/usr/src.

Instalación de SDK

Dado que ahora todas las condiciones de la instalación de VMware vSphere el Burbujea SDK’s están dadas y los ficheros de instalación pueden estar a la disposición nosotros el proceso de instalación verdadero llevan:
cd /usr/src tar -xzvf VMware-vSphere-Perl-SDK-5.0.0-422456.i386.tar.gz cd vmware-vsphere-cli-distrib ./vmware-install.pl
El proceso puede tomar algún tiempo en la pretensión allí todavía algunos Burbujea módulos pueden ser instalados. Release el fichero puede ser apagado a continuación de nuevo:
rm /etc/tmp-release

información que continúa:

http://www.vmware.com/support/developer/vc-sdk/
http://communities.vmware.com / community / vmtn / developer / del foro / vsphere_sdk_perl

Eliminación de falta

Falta: Necesidad CPAN able to install following el Burbujea del módulo on el sistema the. Tesis must installed manually for use by vSphere CLI: El UUID 0.03 or newer

Solución:
cd /usr/src wget http://search.cpan.org/CPAN/authors/id/J/JN/JNH/UUID-0.04.tar.gz
tar -xzvf UUID-0.04.tar.gz cd UUID-0.04 perl Makefile.PL