VMware – Your kernel que built with "gcc" la versión "4/1/3", while you are trying to use "/usr/bin/gcc" la versión "4/3/2"


Un aviso de error repugnante con la instalación del servidor VMware o las herramientas VMware bajo Linux puede presentarse:

El problema

Durante la instalación del servidor VMware bajo Debian y respectivamente Ubuntu o después de la actualización de versión de la distribución el servidor VMware no puede más ser lanzado y lanza el aviso de error siguiente:
Your kernel was built with "gcc" version "4.1.3", while you are trying to use "/usr/bin/gcc" version "4.3.2". This configuration is not recommended and VMware Server may crash if you’ll continue. Please try to use exactly same compiler as one used for building your kernel. Do you want to go with compiler "/usr/bin/gcc" version "4.3.2" anyway? [no]
Si elegís aquí simplemente „yes“, causará a 99,9% de problemas con vuestra instalación. Reconocen así más bien el problema y del camino crean
Con la orden siguiente podéis mirar a las versiones instaladas en el detalle:
ls -la /usr/bin/gcc*
El gasto debía parecer parecido según la versión como junto a mí:
lrwxrwxrwx 1 root root     7 2009-08-04 13:22 /usr/bin/gcc -> /usr/bin/gcc-4.3 -rwxr-xr-x 1 root root 196996 2009-01-18 16:39 /usr/bin/gcc-4.1 -rwxr-xr-x 1 root root 207648 2008-12-31 13:52 /usr/bin/gcc-4.3 -rwxr-xr-x 1 root root 16288 2009-01-18 16:37 /usr/bin/gccbug-4.1
Como miráis, 2 versiones están instaladas en mi sistema: gcc-4.1 y gcc4.3 y el estándar la versión de gcc en gcc-4.3 muestra.

La solución

Ahora el estándar gcc la versión debía ser puesto en el Vesrion gcc-4.1. Es llevable a cabo más de 2 variantes:
Variante1 (el enlace cambian)
ln -s /usr/bin/gcc-4.1 /usr/bin/gcc
Variante2 (Variables de alrededores cambian)
export CC=/usr/bin/gcc-4.1
Después la instalación y respectivamente una nueva configuración no es más ningún problema